Status
Back
Maintenance
Update
Completed 5 May at 11:25pm CEST.
Affected services
Mail
Completed
Update complete
Posted 5 May at 11:25pm CEST.
Started
Installing OS updates
Posted 5 May at 11:00pm CEST.